• Accueil
  • > Archives pour janvier 2011

Archive pour janvier 2011

Installation et configuration de Frugalware 1.3 (Haven) sur Compaq Presario 2500

Mercredi 12 janvier 2011

Bonne nouvelle ! J’ai converti mon frère à Frugalware ! Il possède un ordinateur portable Compaq Presario 2500 et était précédemment sous SliTaz, une très bonne distribution à mon humble avis (de ce que j’en ai vu). Malgré tout, je lui ai conseillé de passer à Frugalware car je m’occupe régulièrement de l’administration de son PC et il n’était pas évident pour moi de passer du mode de fonctionnement d’une distribution à une autre.

Nous avons procédé à l’installation et à la configuration de la distribution Frugalware Linux 1.3 (Haven) sur cet ordinateur. Nous avons d’abord voulu tenter une installation « netinstall », mais nous avons galéré à cause de l’indisponibilité des serveurs FTP belge et français (nous soupçonnons fortement notre fournisseur d’accès sur ce point). Nous nous sommes alors rabattus sur l’installation « classique » à partir des deux premiers CDs. L’installation s’est alors bien déroulée, jusqu’à ce que l’installeur ne puisse pas reconnaitre le deuxième CD (probablement dû à la gravure sur CD-RW). Nous avons été contraints de terminer l’installation avec la moitié des paquets installés.

Le premier démarrage nous a amené tranquillement au login de la console texte (normal, car aucun gestionnaire de connexion n’avait pu être installé).

Avant de configurer un gestionnaire de connexion, nous avons vérifié que la session X était prête à fonctionner. Pour cela, nous avons lancé un premier startx. Cela s’est mal passé : une erreur indiquait que le module radeon n’avait pu être trouvé. Pour résoudre le problème, nous avons commenté toutes les lignes du fichier /etc/X11/xorg.conf.d/20-graphical.conf (et tant pis si cela n’est pas très optimal). Nous avons alors lancé un deuxième startx et la session X s’est lancée avec succès.

Cependant, un autre problème est apparu très rapidement : le touchpad ne fonctionnait pas. Un coup d’œil dans les traces a montré qu’il manquait le module synaptics (pilote de la plupart des touchpads d’ordinateur portable) :

pacman-g2 -S xf86-input-synaptics

Nous avons lancé startx pour la troisième fois, et là, le touchpad a réagi. Nous avons branché une souris USB, et elle a été reconnue immédiatement. Tout semble OK. Pour une fois, j’ai trouvé la configuration de X plutôt facile !

Afin que mon frère ne soit pas trop dépaysé par sa toute nouvelle distribution, je lui ai conseillé d’installer l’environnement de bureau LXDE (bureau par défaut de SliTaz) :

pacman-g2 -S lxde-desktop

Cet environnement vient avec son propre gestionnaire de connexions LXDM. Nous l’avons configuré afin que le système se connecte directement au compte de mon frère. Pour cela, nous avons renseigné le login du compte utilisateur à la propriété autologin, dans le fichier /etc/lxdm/lxdm.conf.

Après redémarrage,  nous avons obtenu ce que nous désirions : le système se connecte au compte utilisateur de mon frère et lance l’environnement de bureau LXDE.

Par défaut, nous nous sommes retrouvés avec un fond d’écran noir. Mon frère souhaitait quelque chose de plus « joli ». Après une longue recherche sur Internet, la solution la plus simple que nous ayons trouvée a été d’exécuter feh au démarrage de l’environnement de bureau. Pour cela, nous avons créé le fichier ~/.config/lxsession/LXDE/autostart avec le contenu suivant :

@feh –bg-scale /usr/share/lxde/wallpapers/lxde_green.jpg

Je ne sais pas si c’est vraiment utile mais nous avons également donné la permission d’exécution au fichier :

chmod +x ~/.config/lxsession/LXDE/autostart

Sous LXDE, le gestionnaire de fichiers est PCManFM. Mon frère avait déjà l’habitude d’utiliser ce logiciel sous SliTaz. Lorsqu’il insérait une clé USB, une entrée apparaissait automatiquement dans PCManFM, lui permettant de monter la clé et de parcourir son contenu. Afin de conserver ce comportement, nous avons créé un répertoire de montage :

mkdir /media/usb

Puis nous avons simplement ajouté la ligne suivante à la fin du fichier /etc/fstab :

/dev/sda1        /media/usb            auto        defaults,noauto,user         1   1

Ainsi, nous associons le périphérique /dev/sda1 (nom usuel du périphérique pour une clé USB) avec le point de montage /media/usb, en autorisant n’importe quel utilisateur à monter/démonter le système de fichier (option user).

Pour le son, nous avons d’abord installé les outils ALSA :

pacman-g2 -S alsa-utils

Ensuite, nous avons exécuté la commande alsaconf et suivi les instructions. La carte son a été bien reconnue et était directement prête à l’emploi.

A cette étape, nous avons cherché désespérément un contrôleur de volume. Après plusieurs dizaines de minutes, nous nous sommes rendus compte qu’un contrôleur de volume était déjà présent dans le tableau de bord LXDE (la barre en bas de l’écran). En fait, comme ce tableau de bord est noir par défaut, et que l’icône du contrôleur de volume est aussi noire, nous n’avions pu le voir…

Afin de disposer d’un écran de démarrage et d’arrêt du système, nous avons installé  splashy :

pacman-g2 -S splashy

Après redémarrage, nous avons malheureusement constaté que l’écran ne s’affichait pas correctement. Au départ, je pensais que l’image s’affichait en vidéo inversé, mais il semble plutôt que le mode vidéo n’ait pas assez de couleurs disponibles pour afficher correctement l’image. Je pense que ce problème vient de la carte graphique de l’ordinateur (ATI Radeon). Je n’ai pas analysé davantage, mon frère ayant considéré le problème comme mineur. Cependant, si vous avez des idées sur ce problème, je serai content de les connaitre.

La dernière étape de la configuration a été d’installer la clé USB Wifi de mon frère. Etant donné qu’il s’agit d’un élément extérieur à l’ordinateur portable lui-même, et que l’opération est un peu longue à expliquer, je préfère garder ce sujet pour un prochain article.

Au final, je pense que mon frère est globalement satisfait de sa nouvelle distribution. Le système démarre assez rapidement et est tout à fait utilisable (comparativement à l’âge de la machine).

Si vous avez des idées alternatives ou des corrections à apporter aux problèmes décrits dans cet article, je vous invite à utiliser les commentaires.

Bilan du blog après un an

Jeudi 6 janvier 2011

Il y a un an exactement, le 6 janvier 2010, j’avais pris la bonne résolution de créer un blog et d’y publier régulièrement des articles. Je m’étais fixé d’écrire au moins un article par mois.

Après une année, la bonne résolution a été tenue et les objectifs ont été dépassés. J’ai publié 28 articles et reçu 8 commentaires. Le blog a été visité environ 3000 fois. Mois après mois, le nombre de visites augmente de façon croissante (avec une exception pour le mois de novembre 2010). En décembre 2010, il y a eu un peu plus de 550 visites.

Je tiens à remercier toutes les personnes qui ont visité mon blog ou qui y ont laissé un commentaire. Ça fait toujours chaud au cœur de savoir que ce qu’on écrit est lu, et a plus ou moins d’intérêt.

Je suis satisfait du site de blogs unblog.fr. Je n’ai jamais subi d’indisponibilité. Il offre toutes les fonctionnalités dont j’avais besoin : sauvegarde d’un brouillon d’article pour publication ultérieure, inclusion d’images dans les articles, catégorisation des articles, flux RSS global et par catégorie.

La modération des commentaires se fait presque automatiquement. Des dizaines de commentaires ont été directement considérées comme du spam. Seuls 4 commentaires ont été à modérer : 2 étaient du spam déguisé, et les 2 autres étaient de vrais commentaires (sur les 8 commentaires ne provenant pas de moi).

Je souhaite que cette année 2011 sera, pour le blog, au moins aussi bonne que l’année passée. J’ai déjà quelques projets d’articles qui, je l’espère, seront utiles pour les internautes.

A bientôt pour une nouvelle année d’articles.