Archive pour mai 2010

Capture d’écran incluant le pointeur de la souris

Dimanche 9 mai 2010

Dans mon message précédent, j’avais parlé du thème par défaut du pointeur de la souris sous Frugalware 1.2 (Locris) et, dans les commentaires, on m’avait demandé une petite capture d’écran. J’avais répondu que je n’avais pas trouvé le moyen de faire une capture d’écran qui inclut le pointeur de la souris.

Je me suis alors lancé dans la recherche d’une solution à ce problème. Après de multiples lectures de forums et de blogs, j’ai trouvé deux outils disposant de la fonctionnalité voulue : Shutter et GIMP.

Ces deux logiciels sont bien évidemment disponibles sous forme de paquets pour Frugalware.

Mon choix s’est porté vers GIMP. Certains me diront surement que c’est un peu le canon pour tuer une mouche mais, Shutter étant un logiciel GNOME, je ne voulais pas installer toutes les dépendances liées à ce paquet.

Pour prendre une capture d’écran incluant le pointeur de la souris avec GIMP, il suffit de choisir l’entrée du menu Fichier > Créer > Capture d’écran… La fenêtre suivante apparait :

Capture d'écran de l'outil de capture d'écran de GIMP

Il suffit alors de sélectionner l’option Prendre une capture d’écran de l’écran entier, de cocher l’option Inclure le pointeur de la souris, de régler un délai et de cliquer sur le bouton Capturer. La capture d’écran se fera au moment du bip et le résultat apparaitra dans une fenêtre d’édition de GIMP.

On peut alors enregistrer le résultat dans le format que l’on souhaite.

Et voici, en guise d’exemples, quelques pointeurs du thème par défaut :

  • le pointeur normal Pointeur normal
  • le pointeur main Pointeur main
  • le pointeur d’atente Pointeur d'attente
  • le curseur de déplacement Pointeur de déplacement

Comme je le disais dans mon message précédent, je n’avais pas été emballé par ce thème aux premiers abords et puis, avec le temps, j’ai fini par m’y habituer, voire même, par les apprécier.

N’hésitez pas à me faire part de vos impressions dans les commentaires.

Mon passage à Frugalware 1.2 (Locris)

Dimanche 2 mai 2010

Cela fait maintenant quelques semaines que j’ai mis à jour ma distribution Frugalware de la version 1.1 (Getorin) vers la version 1.2 (Locris).

J’attendais beaucoup de cette nouvelle version car la version 1.1 m’avait apporté deux grands problèmes.

D’une part, j’avais un problème de mise en veille (dite suspend-to-ram ou mode S3). Lorsque j’exécutais la commande appropriée pour ce genre d’opération (echo -n mem > /sys/power/state), mon ordinateur se mettait bel et bien en veille mais, lors du réveil, le système semblait se bloquer, n’affichant qu’un écran noir avec un curseur clignotant. J’avais essayé d’analyser le problème pendant des heures, mais sans aucun succès.

D’autre part, j’avais également un problème de clavier. J’ai l’habitude d’utiliser les touches dites multimedia de mon clavier pour lancer mes applications usuelles comme sylpheed, firefox et liferea. De temps en temps, le lancement d’une de ces applications déclenchait une charge système importante. Le curseur de la souris restait figé. Le système ne réagissait plus. Bref, tous les indicateurs passaient au rouge. Lorsque j’arrivais (difficilement) à accéder au terminal (Ctrl+Alt+F1), à me connecter et à lister les processus, je constatais des dizaines de processus correspondant à l’application dont j’avais demandé le lancement. Intriguant… Puis, un jour, j’ai voulu supprimer un courriel dans sylpheed, en pressant simplement la touche Suppr. Tout d’un coup, sylpheed s’est mis à supprimer tous les courriels du dossier (je sais maintenant pourquoi le dossier Corbeille existe…). Suite à la répétition de quelques désagréments similaires, j’avais compris peu à peu que tous ces problèmes étaient liés à un même problème : dans certaines circonstances (vraisemblablement lorsque le système était surchargé), la pression d’une touche du clavier semblait se répéter à l’infini. Cependant, malgré de nombreuses recherches, je n’avais jamais pu trouvé la cause de ce comportement.

Voilà pourquoi j’attendais beaucoup Frugalware 1.2 (Locris), espérant que le passage à cette version me fasse oublier ces deux désagréments.

La mise à jour s’est déroulée, comme d’habitude, sans aucun soucis. J’ai pour cela suivi les instructions de mise à jour données par l’équipe de développement, mais adaptées pour pallier la petite taille de mon disque dur.

Dès le redémarrage, je constate le nouveau fond d’écran, plutôt sympa. Puis je me connecte et là, je constate que le thème du pointeur a également changé. Cela est probablement dû au changement de version de X.org. Certains pointeurs (et plus particulièrement le pointeur normal) me paraissaient a priori « vieillottes ». J’étais un peu décontenancé et je prévoyais de changer tout cela. Finalement, après quelques jours, je m’y suis habitué et j’ai décidé de garder ce thème.

J’ai également testé la mise en veille, et j’ai été très content de voir que le système ne s’ai pas bloqué lors du retour de veille. Mais j’ai un peu déchanté lorsque j’ai vu que le pilote ndiswrapper (pilote de mon adaptateur Wifi) semblait ne pas se réinitialiser correctement lors du retour en veille (d’après ce que je vois dans le fichier /var/log/messages).

De retour de veille, je suis donc obligé de décharger le pilote (modprobe -r ndiswrapper) puis de redémarrer le service réseau (service interfaces restart). Mais il ne s’agit pas du problème le plus grave.

En effet, l’initialisation de l’interface Wifi ne fonctionne pas comme auparavant. Le client DHCP (dhcpcd) ne peut pas récupérer une adresse IP de mon routeur et tombe en time out. En regardant d’un peu plus près la configuration de l’interface Wifi (iwconfig wlan0), je remarque que ma clé WEP est correctement renseignée, mais que le ESSID reste à « any/off ». Il faut alors attendre quelques minutes (durée très variable) avant que le ESSID apparaisse, comme par magie, dans la configuration de l’interface Wifi. J’ai passé beaucoup de temps à chercher la cause de ce problème et j’ai essayé de nombreuses solutions (désactivation de IPv6, réinstallation de ndiswrapper et du pilote de l’adaptateur, …) mais cela n’a rien réglé. Je me suis finalement résigné à attendre les quelques minutes d’initialisation de l’adaptateur. Pour cela, j’ai ajouté l’option suivante à mon fichier /etc/sysconfig/network/default :

dhcp_opts = -b

Cette option ordonne au client DHCP de passer en arrière plan avant de récupérer une adresse IP. Cela a deux avantages :

  1. Le démarrage du système est plus rapide car il ne bloque plus sur l’obtention d’une adresse IP à partir d’une (hypothétique) connexion Wifi;
  2. Le client DHCP scrute l’interface Wifi et, lorsque la connexion est établie, demande l’obtention de l’adresse IP.

Concrètement, le temps que le système démarre, que me connecte sur mon système et que je lance mon navigateur, la connexion Wifi est établie et l’adresse IP est obtenue. Cela est satisfaisant mais je ne serai pas étonné d’avoir des problèmes dans le futur.

Pour ce qui est du clavier, le problème est malheureusement encore présent, mais il me semble plus rare.

En résumé, mon passage à Frugalware 1.2 s’est passé sans encombre. Il m’a permis de régler le problème de retour de veille mais l’interface Wifi semble instable et je dois encore analyser les problèmes d’initialisation de cette interface (en particulier lors du retour de veille). Si vous avez des idées, je vous remercie de m’en faire part dans les commentaires.